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Introdução 
 
 

 
O curso tem como objetivos apresentar as funcionalidades e características da 
ferramenta, e principalmente os conceitos de utilização desta ferramenta, de maneira 
que o aluno aprenda a planejar e visualizar o desenvolvimento de seu projeto em Flash, 
Esta apostila vem servir de apoio didático ao curso Flash 5.0 Básico, 
os tópicos foram agrupados por área de assunto e ordenados pensando-se em uma 
seqüência que ajude a formar desde o aprendizado conceitos fundamentais para uma 
utilização profissional e otimizada do Flash 5.0, nesta apostila o aluno encontra material 
de apoio, material de referência e propostas de exercícios práticos. Ao concluir o curso, 
você estará familiarizado com os principais processos de criação/produção de uma 
aplicação em Flash 5.0. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Apresentação 
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Flash é um software desenvolvido pela Macromedia, que possibilita a criação de 
conteúdos multimídia de alta qualidade, interativos e animados, otimizados para a 
publicação na internet. 
 
Conteúdo produzido em Flash pode ser: 
 
• Botões; 
• Banners; 
• Jogos; 
• Formulários; 
• Descanso de Tela; 
• Interfaces de Navegação; 
• Sites. 
 
Um dos primeiros passos no inicio de um projeto é definição da tecnologia utilizada nas 
partes ou processos do projeto, a correta aplicação da ferramenta está intimamente 
ligada com o conhecimento de suas funcionalidades e aplicações, e a escolha da 
ferramenta certa para seu objetivo resultará em resultados mais proveitosos e 
profissionais. 
 
 
 
Características: 
 
Os arquivos criados no Flash guardam e apresentam as informações gráficas 
vetorialmente, isto significa que as imagens são entendidas como formas e 
preenchimentos, e o que é armazenado são os parâmetros destas formas e 
preenchimentos, diferente dos formatos bitmap (mapa de bits), normalmente utilizado 
para armazenamento de fotos e imagens. A imagem de um círculo, por exemplo, 
armazenaria vetorialmente apenas os  
Valores referentes à posição e ao raio deste círculo. Uma imagem bitmap armazena a 
informação da cor de cada pixel que forma o desenho, o que geralmente ocupa muito 
mais espaço. 
 
 
 
 
 
 
 
 
 

Conceitos Iniciais 
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Bitmap (mapa de bits) : 
 

 
 
 
 
 
Comparação: 
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Exemplo Gráfico Vetorial : 
 
 

 
 
 
 
 
Os desenhos vetoriais podem ser redimensionados sem perda da qualidade de 
definição e sem diferença no tamanho do arquivo. 
O seu arquivo de trabalho no Flash, ou arquivo-projeto, é salvo com a extensão.FLA, e é 
como o código fonte de um programa, é nele que você vai desenvolver todo o conteúdo. 
Para a visualização, e publicação deste conteúdo, ele precisa ser exportado para o 
formato.SWF. 
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Conhecendo a Interface do Flash e seus elementos: 
 
 
 
 
 
 
 

 
 
 
 
 
 
 
 
 
 

Explore sua área de trabalho! 
 

Interface 

Barra de Menus 

Barra de Ferramentas 
(desenho) 

Barra de Ferramentas (padrão) 

Timelines / Linhas do Tempo 

Library / Biblioteca 

Atalhos para Panels 
Layers/Camadas 

Stage / Palco 

Panels / Painéis de Configurações 
ZOOM 
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Começando um Projeto: 
 

Vamos começar nosso primeiro projeto utilizando o Flash, e aproveitar para 
conhecer como configurar as principais características de seu Filme. 
Comece um novo Filme. 
Através do menu Modify>Movie (Modificar > Filme)(Ctrl+M) acesse as propriedades de 
seu Filme : 
 
 
 
 
 
 
 
 
 
 
 
 
 
Taxa de Quadros (Frame Rate): 

Define em quantos quadros por segundo seu filme será apresentado, alterando 
este valor é possível conseguir filmes mais detalhados(e demorados) ou filmes 
mais rápidos. 

 
Dimensões (Dimensions): 
 A dimensão de seu Palco, o tamanho final visualizável de seu filme. 
 
Corresponder (Match): Impressora/Conteúdo (Printer/Contents) 

Atribui as dimensões de seu filme para se ajustar ao tamanho do papel 
configurado pela sua impressora, ou a menor área possível com relação ao 
conteúdo já disposto. 

  
Cor do fundo(Background Color): 
 Define a cor de fundo do Filme. 
 
Unidade de medida: 
 Define a unidade de medida de trabalho, a mais cômoda costuma ser pixels. 
 
Explore as configurações disponíveis, são as definições de como seu Filme será 
publicado e apresentado. 
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Desenho Vetorial 
 
 

 
O Flash 5.0 dispõe das principais ferramentas para desenho vetorial. 
Esta é a barra de Ferramentas de Desenho: 

 
 
 
 

 
 
 
 
 
 

Ferramentas 

Seta / Arrow (V) 

Linha / Line (N) 

Caneta / Pen (P) 

Lápis / Pencil (Y) 

Conta Gotas / Dropper (i) 

Oval (O) 

Tinteiro / Ink Botle (S) 

Subseleção / Subselect (A) 

Texto / Text (T) 

Pincel / Brush (B) 

Borracha / Eraser (E) 

Laço / Lasso (L) 

Retângulo / Rectangle (R) 

Balde de Tinta/ Paint Bucket (K) 

Ferramentas de Visualização 

Opções Específicas da 
Ferramenta Selecionada 

Seleção de cores:                    Linha
Preenchimento
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Características do Desenho 
 
A técnica de desenho vetorial possui algumas características, que com a utilização se 
tornam familiar, um desenho vetorial é constituído apenas de Linhas e Preenchimento 
(que podem ser nulos). As linhas quando sobrepostas se associam, já os 
preenchimentos possuem dois comportamentos diferentes, quando da mesma cor, se 
associam, quando de cores distintas, a área de baixo é subtraída. 
Com a resolução dos exercícios propostos, estas e outras características se tornaram 
mais claras.  
 
 
 
 
Exercícios: 
 
01) 
Desenhe linhas, utilizando e explorando as configurações das ferramentas: 
• Linha 
• Caneta 
• Lápis (observe as opções de modo!) 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Opções do Lápis 
(modo da  linha) 
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Faça modificações agora, utilizando as ferramentas: 
• Seta 
• Subseleção 
• Laço 
• Smooth (suavizar, alisar) 
• Straighten (regular) 
• Rotacionar 
• Redimensionar 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Dicas: 
Clicando em Window >Panel >Stroke (Janela > Painéis > Linha), você abre o painel 
específico de configuração de traços: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Opções da Seta: 
snap 
smooth 
straighten 
rotate 
scale 
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02) 
Desenhe formas conhecidas (estrela, sol, etc..) explorando as ferramentas : 
• Oval 
• Retângulo 
• Pincel 
• Balde de Tinta  
• Borracha 
• Contagotas 
 
Assim como no exercício anterior, procure utilizar as opções e os recursos de cada 
ferramenta: 
 

Opções da Borracha 
 
 
 
 
 
 
 
 
 
 
 
De atenção às configurações do Preenchimento!  
 
 
 
 
 
 
Você já sabe onde encontrar mais opções de configuração para esta ferramenta: 
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03) 
Para que servem estas ferramentas? 
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Você pode também importar imagens de outros arquivos, e em outros formatos, através 
do menu File>Import (Arquivo>Importar). Dentre os formatos disponíveis, é possível 
escolher entre importar o conteúdo de um outro arquivo flash, imagens vetoriais em 
outros formatos (freehand, ilustrator, wmf), e imagens bitmaps (.jpg, .gif, .bmp).  
 
 
 

 
Desenhando no Flash vocês devem ter reparado, que muitas vezes é  impossível fazer 
um desenho sem alterar ou confundir-se com outro já pronto, uma das maneira de 
começar a organizar seu conteúdo é agrupando as formas assim como nos softwares 
comuns de edição de imagens. Para tal, selecione as formas que pretende agrupar, e 
clique em Modify > Group (Modificar > Agrupar) ou pressione Ctrl+G. Para editar figuras 
agrupadas, basta dar um duplo-clique sobre a imagem. 
 
Assim como os principais programas de gráficos, o flash também trabalha com layers 
(camadas), controle e operações com as camadas podem ser acessados pelos atalhos: 
 
 

 
É fundamental que se esteja familiarizado a trabalhar com camadas, sua utilização 
facilita a criação e manutenção de seu projeto. 

Imagens Importadas 

Organizando 
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Exercícios: 
04) 
• Comece um novo filme e desenhe uma casa, aplicando os conceitos desenvolvidos 

nos exercícios anteriores. 
• Desenhe um cenário de fundo para sua casa. 
• Salve seu exercício. 
 
 
 
Dicas: 
• Procure identificar quais são os elementos de seu desenho, e trabalhar cada um em 

uma camada diferente. 
• Nomeie as camadas com nomes sugestivos. 
• É possível ocultar ou travar as camadas que desejar, experimente! 
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Símbolos 
 
Para começarmos a utilizar os recursos de animação do Flash, é preciso antes aprender 
a trabalhar com Símbolos. Para o Flash interagir com um elemento, é preciso que este 
elemento seja definido como um objeto, um Símbolo. Como objeto, os símbolos 
possuem propriedades, ações e comportamentos, que poder ser definidos e ou 
alterados no decorrer da animação.  
Ao inserir um símbolo em uma animação, você está inserindo uma instância do objeto 
definido, é como se fosse uma cópia, porém com características diferentes. Instâncias 
de um mesmo símbolo possuem mesmo conteúdo, porém podem possuir propriedades 
e características diferentes. 
 
 
 

 
Existem três tipos possíveis de símbolos: Graphic, Movie Clip e Button (Gráfico, Clipe de 
Filme e Botão), que se diferenciam pelo comportamento e pelas propriedades, que 
conheceremos mais adiante. 
Para transformar uma forma em um símbolo agora, selecione alguma forma em seu 
palco, e clique em Insert>Convert to Symbol (Inserir>Converter para Símbolo), escolha o 
nome do objeto e escolha o tipo do símbolo: Graphic. 
 
 
Descrição dos tipos de Símbolos: 
 
• Graphic(gráfico): Ideal para elementos que não interagem com o filme, a linha de 

tempo dos símbolos do tipo gráfico correm junto com a linha de tempo principal. Não 
realizam ação, nem recebem interação. 

• Movie Clip(clipe de filme): Semelhante ao gráfico, porém possui linha de tempo 
independente, um clipe de filme se comporta como um arquivo flash a parte, pode 
executar ações, e receber controle e interação externa. 

• Button(botão):  Um símbolo do tipo botão, responde a eventos do mouse(up, over, 
down, e hit) e executa ações. 

 
Conheceremos melhor as características de cada tipo de símbolo quando precisarmos 
aplicar os conceitos. 
 

Tipos 
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Quando criamos um símbolo este é arquivado na biblioteca do filme, a partir dela é 
possível gerenciar os objetos de seu filme, organizando, alterando referências, 
visualizando o conteúdo existente. 
Você acessa a biblioteca de seu filme através do menu Window>Library 
(Janela>Biblioteca), ou através do atalho Ctrl+L . 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

exemplo de biblioteca 
 
 
Observe que as imagens importadas também aparecem na biblioteca. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Biblioteca 
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Exercícios: 
05) 
 
• Abra o arquivo biblioteca.fla e copie o símbolo Mouse para um novo filme. 
• Crie instâncias do Mouse, diferenciando uma de outra, aplique efeitos, redimensione. 
• Edite agora o conteúdo do símbolo, e veja o que acontece! 
 
 
 
 
 
 
 
 
 
 

Símbolo “Mouse” do tipo Gráfico 
 

 
• Salve seu exercício. 
 
 
 
Dicas: 
 
• É possível arrastar símbolos de outras bibliotecas para seu filme. 
• É possível abrir um arquivo Flash, como uma biblioteca, experimente. 
• Procure o painel de Instâncias e o de efeitos. 
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Animações 
 
Finalmente o que interessa, Animar! 
Dizemos que o Flash cria conteúdo 3D, isso porque como já devem ter observado, 
temos o plano de desenho (2D) e tudo o que acontece neste plano, acontece em função 
de um Tempo (a terceira dimensão), que é representado pela timeline ou linha-do-
tempo, conheça: 
 
 
 
 
 
 
 
 
 
  
 
 
 
 
 
 
 
 
 
 
 
Cada caixinha na timeline representa um frame (quadro) de sua animação, que roda por 
default a 12fps (frames-por-segundo). Quando iniciamos uma animação, esta contém 
apenas um frame, ou seja, ainda é estática.  
 
 
 
 
 
 
 
 
 
 
 
 
 

Quadro nº: 

Posicionador

Escala da timeline 

Quadro atual 

Taxa de reprodução 

Tempo decorrido 

Onion skins 
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Exercícios: 
06) 
Comece uma nova animação; 
Insira o símbolo “Biplane” disponível em biblioteca.fla 
Insira 30 quadros em seu filme. 
 
 
Observe a alteração na timeline: 
 
 
 
 
 
 
 
 
 
 
 
O Quadrado com a bolinha preta representa um Key Frame, e indica os quadros chave 
da animação, ou seja, onde existe mudança no conteúdo do quadro, o restante dos 
quadros cinzas são Frames(quadros), quando cinza, indicam que o conteúdo do 
KeyFrame imediatamente anterior está presente dos quadros cobertos. O quadradinho 
no fim da animação indica o ultimo quadro em que o conteúdo do KeyFrame aparece. 
É possível desenvolver basicamente, dois tipos de animações no Flash, elas são 
explicadas a seguir: 
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É a mais simples, porém a mais trabalhosa. Para criar animações quadro-a-quadro 
(como o próprio nome sugere), é necessário que se defina todos os quadros da 
animação, ou seja, todo quadro é um quadro-chave (keyframe). 
 
 
 
Exercícios: 
07) 
• Faça uma animação quadro-a-quadro, utilizando um símbolo, ou uma forma 

livre.(sugestão: utilize o símbolo “boneco” do arquivo biblioteca.fla) 
 
 
 
Dicas: 
• Utilize  Modify>Break Apart (Ctrl+B) para quebrar um símbolo em formas novamente. 
• Depois de pronto, explore as opções de “Onion Skin” 
 

Frame by frame (Quadro-a-quadro) 
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O Tweening é a principal forma de animação no Flash, é uma maneira mais fácil de se 
animar, basta definir o quadro chave inicial, e o quadro chave final, e comandar ao Flash 
que realize o tweening. O Flash detecta a mudança, e tenta adivinhar qual era o 
movimento desejado. 
Existem duas formas de Tweening: 
 
 
 

 
Utilizado, para animar símbolos, para a correta utilização do Tweening motion é preciso 
alguns cuidados: 
 
• Somente Símbolos podem ser animados. 
• Somente um Símbolo por Keyframe/Layer deve ser utilizado. 
• O mesmo Símbolo deve estar presente no keyframe inicial e final. 
 
 
 
Exercícios: 
08) 
• Importe o símbolo Águia, de biblioteca.fla, e faça uma animação dela sobrevoando o 

seu palco.  
• Explore as configurações do Tweening (procure o painel Frame) 

• Scale 
• Rotate 
• Easing 

• Adicione efeitos na instância animada, e confira o resultado na animação. 
• É possível fazer a águia percorrer um caminho sinuoso? 
 
• Salve seu exercício. 
 
 
 
 
 
 
 
 
 
 

Tweening (Anumação Linear) 

Tweening Motion 
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Transforma uma forma livre em outra, criando um efeito de “morph”, o procedimento de 
criação é semelhante ao do Tweening Motion, porém os quadros chaves só devem 
conter formas livres. 
 
 
 
Exercícios: 
09) 
• Importe os símbolos da pasta ex9, de biblioteca.fla, e faça animações de forma, 

fazendo uma figura virar outra consecutivamente. (Primeiro transforme os símbolos 
em forma!)  

 
Salve seu exercício. 
 
 
 
Dica:  
• É possível adicionar Shape Hints ao tweening shape, que são dicas de forma, 

através do menu Modify>Transform>Add Shape Hint ou pelo atalho Ctrl+H. 
 
 
 
 

Tweening Shape 
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Botões 
 
Os botões no Flash assim como os gráficos, são símbolos que possuem características 
especiais. Um símbolo do tipo botão possui 3 estágios,  Up (levantado), Over (em cima) 
e Down (abaixado) que representam os comportamentos possíveis de um botão com 
relação ao cursor do Mouse: 
 
• UP : botão solto 
• Over: cursor sobre o botão 
• Down: botão clicando; 
 
E um quarto frame, Hit que representa a área clicavel do botão. 
Observe: 
 
 
 
 
 
 
 
 
 
 
 
Exercícios: 
10) 
• Crie três botões distintos, que sugiram a idéia de Play, Pause, e Volta, com todos os 

estados definidos. 
• Salve seu exercício. 
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Ações Básicas (controle de reprodução) 
 
Para começarmos a controlar nossa animação, e até mesmo para que o uso de botões 
faça sentido, é hora de aprendermos como inserir Ações no Flash. Através de Ações é 
possível controlar a reprodução de um filme, planejar navegação de uma aplicação, 
configurar o modo de visualizaçõ, criar interações das mais diversas com o usuário, 
programar eventos e menus, definir variáveis, interagir com aplicativos externos e até 
mesmo gerar uma animação. É possível definir ações em Frames, em símbolos do tipo 
Movie Clip e em botões. 
Para visualizar as ações disponíveis, clique em Window>Actions (Janela>Ações ), ou 
clique no atalho no canto inferior direito da tela do Flash:  
 
 
 
 
 
Janela de Ações : 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Para Inserir uma ação, basta selecionar um objeto válido, e selecionar a ação que 
deseja atribuir. 
 
 
Exercícios: 
11) 
• Escolha uma das animações feitas 
• Insira os Botões criados no último exercício 
• Adicione as respectivas ações aos botões, de modo a criar um controle da animação. 
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Publicação 
 
Agora que temos uma animação pronta e com controles no Flash, nos resta exportar, 
publicar e visualizar o resultado. 
Sua animação pode ser exportada em diversos formatos, o padrão para animações 
Flash, é a exportação para o Flash Player e Flash Plug-in, onde a animação é compilada 
e recebe a extensão .SWF, e está pronta para ser distribuída, ou inserida em uma 
página HTML . Clique em File>Export (Arquivo>exportar) para verificar os formatos de 
exportação do Flash. 
Para publicar seu filme, escolha primeiramente o modo e os formatos de publicação em 
File>Publish Setings (Arquivo, Configurar Publicação), e escola o formato desejado: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Em seguida clique em Publish (Publicar ), os arquivos selecionados serão gerados no 
diretório em que a animação esta salva. 
 
 
Abra e veja o resultado! 
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Onde obter ajuda 
 
Para ajudá-lo a solucionar dúvidas de informática, utilize o sistema Rau-Tu de perguntas 
e respostas, que foi desenvolvido pelo Centro de Computação da Unicamp em conjunto 
com o Instituto Vale do Futuro. Tem por objetivo possibilitar que um time de 
colaboradores possa responder a perguntas colocadas por qualquer pessoa no site, 
cobrindo diversas áreas de conhecimento. 
Acesse: www.rau-tu.unicamp.br 
 
 


